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Overview 

Welcome to the manual for the DirectShow based Encoder, which is used with 

the Wavedec, BlitzVIDEO and DarkVIDEO products. Apart from the file extension 

used for each of the different products (for the main document type and 

generated videos), operation and usage of the encoder is exactly the same. We 

use the DarkVIDEO version of the encoder in this manual. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Prerequisites 

Before we take a tour of the interface, it's important to know that the encoder 

utilises Microsoft's DirectShow to decode input movies so that they can be 

passed onto the decoder core, to be encoded into either wvf (Wavedec), bvf 

(BlitzVIDEO) or dvf (DarkVIDEO) format. Depending on the type of movie you're 

trying to transcode, you may find that you don't have the required codecs 

installed and so, the encode process fails. 

For example, you may have a simple uncompressed AVI, maybe like the sample 

video that comes with the encoder (sample.avi) and this will work fine. However, 

if you have a movie that's using newer formats like x264, h264 etc, you'll 

probably need an equivalent codec installed. We recommend the Combined 

Community Codec Pack. 

After installing this pack, you should have no problems with encoding. Beware as 

some other codec packs contain broken codecs that don't decode correctly. 
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Quick start 

On starting up the encoder, you'll be greeted with a sight similar to the 

following: 

 

We now present a very quick overview to using the encoder, after which, a more 

detailed look follows. 

If this is your first time using the encoder, you'll find it's quite intuitive after a 

few tries. The very first version of the encoder used to work on the concept of 

transcoding a single movie. The new version works on the concept of 

transcoding multiple movies, so as to save the user time. 

First of all, you need to select a folder that contains the movies you're interested 

in encoding for this session. Let's take a look at the left pane in more detail, the 

Folder pane: 



 

You can see that we're able to select a complete path to the folder that contains 

our movies. In this instance, the H:\ drive root has been expanded. Whenever 

we select a folder with the mouse, the encoder will take a look inside to see if 

there are any valid movies. Right now, nothing has happened because we only 

clicked the expand icon to the left of the drive. But if we were to click on the 

actual drive, we'd all of a sudden see some videos appear in the Video pane, like 

so: 

 

 

So, after simply selecting the H:\ drive (or any drive on your system), the 

encoder, having found valid videos, shows them in the Video pane. The encoder 

would now look similar to the following: 



 

At this point, you could change the options in the Properties pane (quality, scale 

type etc) but let's assume that we're happy with the default options and we just 

want to encode. Let's take a look at the toolbar: 

 

Take a look at the fourth icon, which is greyed out. This is the Encode button 

and pressing it will initiate an encoding session. It's greyed out because we 

haven't selected any movies to encode. We can select multiple movies to encode 

for a session from within the Video pane. Here, I'm only interested in encoding 

the movie called sample.avi, so I'll select it, by checking the checkbox on the 

left, noticing that the Encode button is no longer greyed out: 

 

 

Short of setting any options, that's really all there is to it. Once you press the 

Encode button, the encode session will start and all of your selected movies will 

be encoded one by one. You'll have noticed the two black frames above the 

Video pane. These show the progress of the current movie encode, the original 

extracted frame on the left, the current frame on the right, so you can be 

comparing quality on the fly. Of course, you can cancel the encode session at 

any time. 



The image below shows the encode session in progress (the clip is constructed 

from frames from the open movie Elephants Dream, used under the Creative 

Commons License): 
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The Encoder In Depth 

The Menu 

The File Menu 

 

The File Menu contains five items that mainly revolve around encoder 

documents. The extension is different depending on which product you're using 

(wve for Wavedec, bve for BlitzVIDEO and dve for DarkVIDEO). A document in 

the encoder is used to store the state. For example, imagine you've browsed to 

a G:\ drive and selected six of nine movies. Rather than having to reselect this 

later on, you can save this state for later retrieval. This saves you having to 

waste time at a later date, where instead, you can simply load the state from 

the saved document. From top to bottom: 

 New - Create a new document, taking a snapshot of the current state. 

 Open - Open an existing document, setting the current state from it. 

 Save - Save the current state to an already saved document or prompt 

the user if one hasn't yet been saved. 

 Save As - Save the current state to a new/existing document. 

 Exit - Exit the program. 

 

 

 

 

 

 



The Edit Menu 

 

The Edit Menu is pretty sparsely populated, containing only one option, the 

ability to invoke the Preferences Dialog. From top to bottom: 

 Preferences - Show the Preferences Dialog. The Preferences Dialog is 

pretty simple, as seen below: 

 

As you can see, there are really only two things to set, and right now, 

DirectShow is the only option for both of them. These settings relate to how the 

encoder will get the audio and video from the selected original movie into the 

encoder core. In the future, ffmpeg will most likely be added as an option. 

 

 

 

 

 

 



The View Menu 

 

There are quite a few options in the Video Menu. They mainly involve changing 

the layout of the interface and altering the selection of movies in the Video pane. 

From top to bottom: 

 Toolbars - This shows a submenu that allows you to select which of the 

toolbars you want to show. This includes the main toolbar as well as each 

of the dockable panes (Folder, Properties, Video and Log), which are 

considered to be toolbars. 

 Status Bar - This allows you to toggle showing the status bar at the 

bottom of the window. 

 Split - This allows you to change the split between the two preview panes 

(see The Preview Panes). 

 Application Look - This allows you to change the look of the app, so if 

you'd rather have a Windows XP or Visual Studio.NET 2005 look, this is 

where you'd set it. 

 Select All Movies - Once you've browsed to a valid location that contains 

movies, this will select all movies in the Video pane. It's greyed out if 

there's no valid location selected. 

 Deselect All Movies - Likewise, if a valid location that contains movies has 

been selected, this will deselect all movies in the Video pane. It's greyed 

out if there's no valid location selected. 

 Invert Movie Selection - Again, if a valid location that contains movies has 

been selected, this will invert the selection so that all selected movies are 

deselected and all deselected movies are selected in the Video pane. It's 

greyed out if there's no valid location selected. 

 



The Help Menu 

 

The Help Menu, as you'd expect, contains options designed to help you get the 

most out of the encoder. From top to bottom: 

 About - Shows information about the encoder. 

 Encoder Manual - Spawns this manual that you're reading right now. 

 Get Combined Community Codec Pack - This will take you to the CCCP 

webpage so that you can download our recommended codec pack. 

Without a decent codec pack, as mentioned above in Prerequisites, you 

may run into difficulties encoding, as DirectShow is unable to resolve 

some codec types without external help. 

 Visit Deep Cove Software - Spawns Deep Cove Software's webpage so 

that you can check for a new version etc. 

 

 

 

 

 

 

 

 

 

 



The Toolbar 

 

The toolbar contains a selection of commands from the various menus, with a 

few new ones, namely Encode and Partner Site. From left to right: 

 New - Create a new document, taking a snapshot of the current state. 

 Open - Open an existing document, setting the current state from it. 

 Save - Save the current state to an already saved document or prompt 

the user if one hasn't yet been saved. 

 Encode - Encodes the selected movie in the Video pane. This will be 

greyed out if no movies are selected. 

 Visit Deep Cove Software - Spawns Deep Cove Software's webpage so 

that you can check for a new version etc. 

 Visit Partner - This will take you to the site of the tool this product is 

connected with. For example, with BlitzVIDEO, you'd be taken to 

http://www.blitzbasic.com, whereas with DarkVIDEO, you'd be taken to 

http://www.thegamecreators.com. 
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The Preview Panes 

 

The preview panes serve a couple of purposes, firstly showing the progress of 

the current movie being encoded and secondly, to show you the difference 

between the original frame and the frame compressed by the encoder core.  

In the encode session above, we set the encode quality to Ultra Low. You can 

see that the frame from the encoder core (on the right) is quite a bit worse 

quality than the original frame (on the left), just as you'd expect by selecting a 

setting like this. By being able to quickly identify that the quality is not good 

enough, you're able to cancel, saving valuable time. 

The clip is constructed from frames from the open movie Elephants Dream, used 

under the Creative Commons License. 
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The Folder Pane 

 

The Folder pane makes it easy for you browse to a folder that contains movies 

you're interested in encoding. It's very reminiscent of Windows Explorer and so 

needs little explanation. 

Something to remember is that clicking the expand buttons alone is not enough 

to instruct the encoder to investigate movies. You actually have to select a folder 

to initiate the encoder scanning for movies. For example, clicking the H:\ drive 

below will cause the encoder to look for movies in the root of H:\. 

 

 

 

 



The Properties Pane 

 

There are quite a few options in the Properties pane. Most of them are in relation 

to the encoding. From top to bottom: 

Preview 

 Show - This simply sets whether to show the frame from DirectShow in 

the left preview pane and the frame from the encoder core in the right 

preview pane. 

 Aspect Corrected - This controls whether the frames shown in the preview 

panes will fill the whole area or be aspect corrected. The aspect correction 

goes simply on the movie dimensions and doesn't extract any information 

from the movie that it's supposed to be anamorphic. For example, 

imagine you had a clip that's supposed to be anamorphic 16:9 or 2:35 to 

1 with dimensions something like 720x432. The encoder will take the 

aspect ratio to be 720 / 432 = 1.67 to 1, rather than 2:35 to 1. This 

setting is mainly to present the video frame somewhat like it's intended. 

It's not meant to be super accurate. 

Movie 

 Encrypt - This will apply a simple xor based encryption to the movie. It's 

not recommended as it slows down the decode process. This may be 

expanded in the future to allow the same simple xor based encryption to 

use a user supplied key instead. 

Video Compression 



 Quality - This controls the quality of the encoded movie, from Ultra High 

to Ultra Low. Ultra High is NOT recommended as it creates effectively 

lossless videos that are quite huge in comparison to the other settings. 

High is the default although Very High is recommended if you're not too 

bothered about a larger (but not much larger) movie. 

 Method - This is the internal method the encoder core will use to encode 

the video. The latest version is method 4 which is over three times faster 

than the very first version, method 1. This is mainly intended for 

development and is not selectable by end users. 

 Scale - If the movie is going to be scaled, either because the dimensions 

are not an exact multiple of 16 or because scale to a known texture size is 

required, this setting controls how the scale will be applied. There are 

many settings, Fast Bilinear being the recommended setting. Settings like 

Sinc, Lancsoz and Spline will give a better result at the expense of 

computation time. 

 Scale to texture size - This controls if the movie will be scaled to a known 

texture size. This setting is very handy if powers of two texture sized 

movies are desired. 

 Texture width - The width to scale to when Scale to texture size is 

enabled. 

 Texture height - The height to scale to when Scale to texture size is 

enabled. 

Audio Compression 

 Quality - This controls the quality of the encoded audio, from 0.1 to 1.0. 

There's hardly any audible difference between the settings but 0.2 is 

recommended as the best balance. 

 Method - This is the internal method the encoder core will use to encode 

the audio. Currently, only VBR (variable bit rate) is available. 

 

 

 

 

 

 

 

 



The Video Pane 

 

Once a valid folder that contains movies has been selected in the Folder pane, 

the Video pane will update to show what movies are actually in this folder. 

There's quite a bit of information it shows you and from left to right, here's an 

explanation: 

 Name - This simply lets you know what the name of the movie is. 

Currently, the encoder can understand AVI and WMV movies. 

 Size - Here, you can see the size of the movie. This field will let you know 

whether it's in the megabyte or gigabyte range so you've got a good idea 

of just how big it is. 

 Width - This simply lets you know the width of the movie. Take a look at 

the first movie's width field. You can see it's simply 640. Now, take a look 

at the second movie's width field. You can see it's 716 but there's another 

number in parentheses, which is 720. The reason this number is there is 

because the encoder core requires that the width of a movie be an exact 

multiple of 16. 716 isn't an exact multiple of 16 but 640 for the first movie 

is and 720 for the second movie is. When you see a number in 

parentheses to the right of another number, in this case 716 (720), it 

means the original width, the first number, will be scaled to the second 

number. You're able to set the scale type in the Properties pane, favouring 

quality or speed. 

 Height - This simply lets you know the height of the movie. Just like the 

width field, a second number in parentheses means exactly the same, that 

a scale is going to take place because the first number (the original 

height) isn't an exact multiple of 16. 

 Frame rate - Here, you can see what the frame rate of the movie is. 

 Type - Here, you can see whether this movie is an AVI or WMV. 

 Audio - Whether the movie contains an audio stream. 

 

 

 

 

 

 



The Log Pane 

 

The Log Pane is there to inform you of information and progress as the encode 

session is happening. It'll tell you if something went wrong, whether everything 

went ok, information about the movie etc. 

This pane will be switched to automatically when the encode session starts so 

remember to switch back to the Video pane when you're selecting a new folder 

from the Folder pane. 

 

 

 

 

 

 

 

 

 

 

 

 

 



Tips 

 The sample video ("sample.avi") is encoded as a CINEPAK AVI so as to be 
accessible to everyone, regardless of installed codecs. It's not the greatest 

quality so as to keep the movie size relatively small and thus, keeping the 
setup size down. So, it's recommended to try DarkVIDEO with higher 

quality source material to see just what it's capable of. Remember, the 
higher quality the source material, the higher quality movies the encoder 
can create. 

 For the very best encoder and decoder performance, we recommend that 
you ensure your movies have dimensions that are a power of two. For 

example, 256x256 or 512x512 etc. This is so there's no conversion step to 
get the movie frame into a texture friendly size on the Direct3D side. For 
example, a movie of 777 x 444 will likely have a texture of 1024 x 512 

created. As of version 2 of the encoder, you're able to instruct to encoder 
to scale to a known texture size, using any of multiple scalers. 

 As well as ensuring your movies have dimensions that are a power of two, 
for optimal encoder performance, you should ensure that your movie 
dimensions are exact multiples of 16. If the encoder detects they're not, 

it'll automatically scale each frame to the nearest multiple of 16 before 
encoding (this is a requirement of how DarkVIDEO works internally and 

what allows a lot of the optimisations to be possible). Whilst this is handy, 
it does come at a price in that the encoding is not as fast as it could be. 

 If you want to use the encoder to encode AVIs containing streams such as 

x264 or MP3, you need to install the correct codecs. One good set, as 
recommended above, is the Combined Community Codec Pack. 
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Trial Version 

Until the encoder is registered, the following restrictions apply: 

 The encoder will work for 21 days and then cease to start up after this 

period. 

 All encoded movies will have a small watermark placed in the top left 

corner of the movie. 

 


